GHSA-ff77-26x5-69cr

Apache Tomcat Rewrite rule bypass

En bref

Publiée
Mise à jour
CVE
CVE-2025-31651
Alias
BIT-tomcat-2025-31651
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U

Description

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. For a subset of unlikely rewrite rule configurations, it was possible for a specially crafted request to bypass some rewrite rules. If those rewrite rules effectively enforced security constraints, those constraints could be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.5, from 10.1.0-M1 through 10.1.39, from 9.0.0.M1 through 9.0.102. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6, which fix the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-catalinaintroduced 9.0.76, fixed 9.0.104
Maven · org.apache.tomcat:tomcat-catalinaintroduced 10.1.10, fixed 10.1.40
Maven · org.apache.tomcat:tomcat-catalinaintroduced 11.0.0-M2, fixed 11.0.6
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.76, fixed 9.0.104
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.10, fixed 10.1.40
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.0-M2, fixed 11.0.6
Maven · org.apache.tomcat:tomcat-catalinaintroduced 8.5.0, last affected 8.5.100
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 8.5.0, last affected 8.5.100

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database