GHSA-f98p-9pp6-7q6c

Apache Tomcat Cross-site scripting (XSS) vulnerability

At a glance

Published
Updated
CVE
CVE-2008-1947
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

Cross-site scripting (XSS) vulnerability in Apache Tomcat 5.5.9 through 5.5.26 and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via the name parameter (aka the hostname attribute) to `host-manager/html/add`.

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcatintroduced 5.5.9, fixed 5.5.27
Maven · org.apache.tomcat:tomcatintroduced 6.0.0, fixed 6.0.18
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 5.5.9, fixed 5.5.27
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 6.0.0, fixed 6.0.18

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database