GHSA-f92j-qf46-p6vm

Reflected Cross-site Scripting in ACS Commons

At a glance

Published
Updated
CVE
CVE-2021-21028, CVE-2021-21043
Aliases
GHSA-7r83-w6r8-fh6w

Description

### Impact ACS Commons version 4.9.2 (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful. ### Patches This issue has been resolved in v4.10.0 ### Workarounds No workaround exist. ### References N/A ### For more information If you have any questions or comments about this advisory open an issue in acs-aem-commons. ### Credit This issue was discovered and reported by Christopher Whipp (Christopher.Whipp@servicesaustralia.gov.au).

Affected packages

PackageVersions
Maven · com.adobe.acs:acs-aem-commonsintroduced 0, fixed 4.10.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database