GHSA-f5w3-73h4-jpcm
mongosh vulnerable to local privilege escalation
At a glance
- Published
- Updated
- CVE
- CVE-2025-1756
- CVSS_V3
- CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
Description
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules\. This issue affects mongosh prior to 2.3.0.
Affected packages
| Package | Versions |
|---|---|
| npm · mongosh | introduced 0, fixed 2.3.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-1756 ADVISORY
- https://access.redhat.com/errata/RHSA-2025:1756 WEB
- https://github.com/mongodb-js/mongosh PACKAGE
- https://jira.mongodb.org/browse/MONGOSH-2028 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |