GHSA-f58c-gq56-vjjf
Apache Tika has XXE vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-66516
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Description
Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways. First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable. Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.apache.tika:tika-core | introduced 1.13, fixed 3.2.2 |
| Maven · org.apache.tika:tika-parsers | introduced 1.13, fixed 2.0.0 |
| Maven · org.apache.tika:tika-parser-pdf-module | introduced 2.0.0, fixed 3.2.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2025-66516 ADVISORY
- https://cve.org/CVERecord?id=CVE-2025-54988 WEB
- https://github.com/apache/tika PACKAGE
- https://lists.apache.org/thread/s5x3k93nhbkqzztp1olxotoyjpdlps9k WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |