GHSA-f554-x222-wgf7

Command Injection in Xstream

En bref

Publiée
Mise à jour
CVE
CVE-2013-7285
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not been initialized, may allow a remote attacker to run arbitrary shell commands by manipulating the processed input stream when unmarshaling XML or any supported format. e.g. JSON.

Paquets affectés

PaquetVersions
Maven · com.thoughtworks.xstream:xstreamintroduced 0, fixed 1.4.7
Maven · com.thoughtworks.xstream:xstreamintroduced 1.4.10, fixed 1.4.11

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database