GHSA-f525-44xv-f2qj

Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation

En bref

Publiée
Mise à jour
CVE
CVE-2026-65637
Alias
BIT-tomcat-2026-65637
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-coyoteintroduced 11.0.20, fixed 11.0.25
Maven · org.apache.tomcat:tomcat-coyoteintroduced 10.1.53, fixed 10.1.59
Maven · org.apache.tomcat:tomcat-coyoteintroduced 9.0.115, fixed 9.0.121
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.20, fixed 11.0.25
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.53, fixed 10.1.59
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.115, fixed 9.0.121

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database