GHSA-f4qf-m5gf-8jm8

Apache Tomcat vulnerable to Generation of Error Message Containing Sensitive Information

At a glance

Published
Updated
CVE
CVE-2024-21733
Aliases
BIT-tomcat-2024-21733
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Description

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcat-coyoteintroduced 9.0.0-M11, fixed 9.0.44
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 8.5.7, fixed 8.5.64
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.0-M11, fixed 9.0.44
Maven · org.apache.tomcat:tomcat-coyoteintroduced 8.5.7, fixed 8.5.64
Maven · org.apache.tomcat.experimental:tomcat-embed-programmaticintroduced 9.0.43, fixed 9.0.44

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database