GHSA-cwfw-4gq5-mrqx

Regular Expression Denial of Service (ReDoS) in braces

At a glance

Published
Updated
CVE
CVE-2018-1109

Description

A vulnerability was found in Braces versions from v2.2.0 up to but not including v2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks. This has been patched in version 2.3.1.

Affected packages

PackageVersions
npm · bracesintroduced 2.2.0, fixed 2.3.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database