GHSA-cvf4-f829-762v

pgAdmin is affected by an LDAP injection vulnerability

At a glance

Published
Updated
CVE
CVE-2025-12764
Aliases
PYSEC-2026-1772
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

pgAdmin <= 9.9 is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amount of data DOS.

Affected packages

PackageVersions
PyPI · pgadmin4introduced 0, fixed 9.10

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database