GHSA-cr3q-pqgq-m8c2
Spoofing attack in swagger-ui
At a glance
- Published
- Updated
- CVE
- CVE-2018-25031
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Description
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
Affected packages
| Package | Versions |
|---|---|
| npm · swagger-ui | introduced 0, fixed 4.1.3 |
| Maven · org.webjars:swagger-ui | introduced 0, fixed 4.1.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-25031 ADVISORY
- https://github.com/swagger-api/swagger-ui/issues/4872 WEB
- https://github.com/swagger-api/swagger-ui/pull/7697 WEB
- https://github.com/swagger-api/swagger-ui PACKAGE
- https://github.com/swagger-api/swagger-ui/releases/tag/v4.1.3 WEB
- https://security.netapp.com/advisory/ntap-20220407-0004 WEB
- https://security.snyk.io/vuln/SNYK-JS-SWAGGERUI-2314885 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |