GHSA-cr3q-pqgq-m8c2

Spoofing attack in swagger-ui

At a glance

Published
Updated
CVE
CVE-2018-25031
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

Description

Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.

Affected packages

PackageVersions
npm · swagger-uiintroduced 0, fixed 4.1.3
Maven · org.webjars:swagger-uiintroduced 0, fixed 4.1.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database