GHSA-cpw7-g3p5-qrfq

Apache ActiveMQ server has an incomplete authorization workflow

At a glance

Published
Updated
CVE
CVE-2026-46605
Aliases
BIT-activemq-2026-46605
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Description

Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.activemq:apache-activemqintroduced 0, fixed 5.19.7
Maven · org.apache.activemq:apache-activemqintroduced 6.0.0, fixed 6.2.6

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database