GHSA-cmwx-9m2h-x7v4

Ansible apt_key module does not properly verify key fingerprint

At a glance

Published
Updated
CVE
CVE-2016-8614
Aliases
PYSEC-2018-37
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Description

A flaw was found in Ansible before version 2.2.0.0. The `apt_key` module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.

Affected packages

PackageVersions
PyPI · ansibleintroduced 0, fixed 2.2.0.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database