GHSA-cmmh-8mwp-gq5p

Drupal Cross Site Scripting (XSS) vulnerability

At a glance

Published
Updated
CVE
CVE-2019-6341
Aliases
DRUPAL-CORE-2019-004
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File `module/subsystem` allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.

Affected packages

PackageVersions
Packagist · drupal/coreintroduced 7.0.0, fixed 7.65.0
Packagist · drupal/coreintroduced 8.0.0, fixed 8.5.14
Packagist · drupal/coreintroduced 8.6.0, fixed 8.6.13
Packagist · drupal/drupalintroduced 7.0.0, fixed 7.65.0
Packagist · drupal/drupalintroduced 8.0.0, fixed 8.5.14
Packagist · drupal/drupalintroduced 8.6.0, fixed 8.6.13

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database