GHSA-cmjc-qp7j-xgwr
WSO2 carbon-apimgt affected by an authenticated stored cross-site scripting (XSS) vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2025-4760
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Description
An authenticated stored Cross-Site Scripting (XSS) vulnerability exists in WSO2 API Manager components (`carbon-apimgt`) due to insufficient validation of user-supplied input during API document upload in the Publisher portal. A user with publisher privileges can upload a crafted API document whose contents are later rendered in the UI for other users, leading to attacker-controlled script execution. Likely outcomes include redirection to malicious sites, unauthorized UI modifications, or exfiltration of data accessible to the browser; session hijacking is mitigated by the use of `HttpOnly` session cookies. To remediate, update to version 9.31.117 or above.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.api | introduced 0, fixed 9.31.117 |
| Maven · org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.publisher.v1 | introduced 0, fixed 9.31.117 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-4760 ADVISORY
- https://github.com/wso2/carbon-apimgt/pull/13099 WEB
- https://github.com/wso2/carbon-apimgt/commit/1b3496c072ec68aaaf726996e2caa76f07c1adca WEB
- https://github.com/wso2/carbon-apimgt PACKAGE
- https://mvnrepository.com/artifact/org.wso2.carbon.apimgt/org.wso2.carbon.apimgt.api/9.31.117 WEB
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2025/WSO2-2025-4104 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |