GHSA-cjjc-xp8v-855w

Helm uses crypto package vulnerable to panic from malformed X.509 certificate

At a glance

Published
Updated
CVE
CVE-2020-7919
Aliases
BIT-golang-2020-7919, GO-2022-0229
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

The Helm core maintainers have identified a high severity security vulnerability in Go's `crypto` package affecting all versions prior to Helm 2.16.8 and Helm 3.1.0. Thanks to @ravin9249 for identifying the vulnerability. ### Impact Go before 1.12.16 and 1.13.x before 1.13.7 (and the `crypto/cryptobyte` package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows attacks on clients resulting in a panic via a malformed X.509 certificate. This may allow a remote attacker to cause a denial of service. ### Patches A patch to compile Helm against Go 1.14.4 has been provided for Helm 2 and is available in Helm 2.16.8. Helm 3.1.0 and newer are compiled against Go 1.13.7+. ### Workarounds No workaround is available. Users are urged to upgrade. ### References - https://nvd.nist.gov/vuln/detail/CVE-2020-7919 - https://github.com/helm/helm/pull/8288 ### For more information If you have any questions or comments about this advisory: * Open an issue in [the Helm repository](https://github.com/helm/helm/issues) * For security-specific issues, email us at <cncf-helm-security@lists.cncf.io>

Affected packages

PackageVersions
Go · github.com/helm/helmintroduced 2.0.0, fixed 2.16.8
Go · helm.sh/helm/v3introduced 3.0.0, fixed 3.1.0
Go · golang.org/x/cryptointroduced 0, fixed 0.0.0-20200124225646-8b5121be2f68

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database