GHSA-cj7w-pm77-hvg6

Magento XML Injection vulnerability in the Widgets Module

At a glance

Published
Updated
CVE
CVE-2022-34253
Aliases
BIT-magento-2022-34253
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an XML Injection vulnerability in the Widgets Module. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution. Exploitation of this issue does not require user interaction.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 0, fixed 2.3.7-p4
Packagist · magento/community-editionintroduced 2.4.4, fixed 2.4.5
Packagist · magento/community-editionintroduced 2.4.0, fixed 2.4.3-p3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database