GHSA-cj43-9h3w-v976

Puppet allows remote attackers to execute arbitrary Ruby programs from the master via the resource_type service

At a glance

Published
Updated
CVE
CVE-2013-4761

Description

Unspecified vulnerability in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, allows remote attackers to execute arbitrary Ruby programs from the master via the resource_type service. NOTE: this vulnerability can only be exploited utilizing unspecified "local file system access" to the Puppet Master.

Affected packages

PackageVersions
RubyGems · puppetintroduced 2.7.0, fixed 2.7.23
RubyGems · puppetintroduced 3.2.0, fixed 3.2.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database