GHSA-cgx2-rrmr-jx43
Apache Airflow vulnerable to sensitive information exposure when users list warnings for all DAGs
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-42780
- Alias
- BIT-airflow-2023-42780, PYSEC-2023-202
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Description
Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.7.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-42780 ADVISORY
- https://github.com/apache/airflow/pull/34355 WEB
- https://github.com/apache/airflow/commit/cf4eb3fb9b5cf4a8369b890e39523d4c05eed161 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-202.yaml WEB
- https://lists.apache.org/thread/h5tvsvov8j55wojt5sojdprs05oby34d WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |