GHSA-cf46-6xxh-pc75

libxslt Type Confusion vulnerability that affects Nokogiri

At a glance

Published
Updated
CVE
CVE-2019-13118
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

In `numbers.c` in libxslt 1.1.33, a type holding grouping characters of an `xsl:number` instruction was too narrow and an invalid character/length combination could be passed to `xsltNumberFormatDecimal`, leading to a read of uninitialized stack data. Nokogiri prior to version 1.10.5 used a vulnerable version of libxslt. Nokogiri 1.10.5 updated libxslt to version 1.1.34 to address this and other vulnerabilities in libxslt.

Affected packages

PackageVersions
RubyGems · nokogiriintroduced 0, fixed 1.10.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database