GHSA-c87w-642h-m97h

Apache Ranger has a Code Injection vulnerability

At a glance

Published
Updated
CVE
CVE-2025-59059
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.

Affected packages

PackageVersions
Maven · org.apache.ranger:ranger-plugins-commonintroduced 0, fixed 2.8.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database