GHSA-c75v-2vq8-878f

Angular vulnerable to Cross-site Scripting

At a glance

Published
Updated
CVE
CVE-2021-4231
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 10.2.5, 11.0.5 or 11.1.0-next.3 is advised to to address this issue.

Affected packages

PackageVersions
npm · @angular/coreintroduced 11.0.0, fixed 11.0.5
npm · @angular/coreintroduced 11.1.0-next.0, fixed 11.1.0-next.3
npm · @angular/coreintroduced 0, fixed 10.2.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database