GHSA-c45w-p293-7cv6

Magento 2 Community Edition XSS Vulnerability

At a glance

Published
Updated
CVE
CVE-2019-7945
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

A stored cross-cite scripting vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to modify currency symbols can inject malicious javascript.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.1.0, fixed 2.1.18
Packagist · magento/community-editionintroduced 2.2.0, fixed 2.2.9
Packagist · magento/community-editionintroduced 2.3.0, fixed 2.3.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database