GHSA-c392-whpc-vfpr

Apache Airflow vulnerable to Improper Encoding or Escaping of Output

At a glance

Published
Updated
CVE
CVE-2024-45498
Aliases
BIT-airflow-2024-45498, PYSEC-2024-266
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

Example DAG: example_inlet_event_extra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated attacker with only DAG trigger permission to execute arbitrary commands. If you used that example as the base of your DAGs - please review if you have not copied the dangerous example; see https://github.com/apache/airflow/pull/41873  for more information. We recommend against exposing the example DAGs in your deployment. If you must expose the example DAGs, upgrade Airflow to version 2.10.1 or later.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 2.10.0, fixed 2.10.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database