GHSA-c2qf-rxjj-qqgw

semver vulnerable to Regular Expression Denial of Service

At a glance

Published
Updated
CVE
CVE-2022-25883
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Versions of the package semver before 7.5.2 on the 7.x branch, before 6.3.1 on the 6.x branch, and all other versions before 5.7.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the function new Range, when untrusted user data is provided as a range.

Affected packages

PackageVersions
npm · semverintroduced 7.0.0, fixed 7.5.2
npm · semverintroduced 6.0.0, fixed 6.3.1
npm · semverintroduced 2.0.0-alpha, fixed 5.7.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database