GHSA-9w5j-4mwv-2wj8

Remote code execution in simple-git

En bref

Publiée
Mise à jour
CVE
CVE-2022-25860
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Versions of the package simple-git before 3.16.0 are vulnerable to Remote Code Execution (RCE) via the clone(), pull(), push() and listRemote() methods, due to improper input sanitization. This vulnerability exists due to an incomplete fix of CVE-2022-25912.

Paquets affectés

PaquetVersions
npm · simple-gitintroduced 0, fixed 3.16.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database