GHSA-9v3m-8fp8-mj99

Bootstrap Vulnerable to Cross-Site Scripting

En bref

Publiée
Mise à jour
CVE
CVE-2019-8331
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Versions of `bootstrap` prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The `data-template` attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript. ## Recommendation For `bootstrap` 4.x upgrade to 4.3.1 or later. For `bootstrap` 3.x upgrade to 3.4.1 or later.

Paquets affectés

PaquetVersions
RubyGems · bootstrapintroduced 0, fixed 4.3.1
RubyGems · bootstrap-sassintroduced 3.0.0, fixed 3.4.1
NuGet · Bootstrap.Lessintroduced 3.0.0, fixed 3.4.1
NuGet · bootstrapintroduced 4.0.0, fixed 4.3.1
NuGet · bootstrapintroduced 3.0.0, fixed 3.4.1
NuGet · bootstrap.sassintroduced 0, fixed 4.3.1
npm · bootstrapintroduced 4.0.0, fixed 4.3.1
npm · bootstrapintroduced 3.0.0, fixed 3.4.1
npm · bootstrap-sassintroduced 3.0.0, fixed 3.4.1
RubyGems · twitter-bootstrap-railsintroduced 0, fixed 5.3.0
Maven · org.webjars:bootstrapintroduced 3.0.0, fixed 3.4.1
Maven · org.webjars:bootstrapintroduced 4.0.0, fixed 4.3.1
Packagist · twbs/bootstrapintroduced 3.0.0, fixed 3.4.1
Packagist · twbs/bootstrapintroduced 4.0.0, fixed 4.3.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database