GHSA-9q3g-m353-cp4p
Denial of Service in Packetbeat
At a glance
- Published
- Updated
- CVE
- CVE-2017-11480
- Aliases
- GO-2022-0643
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
Packetbeat versions prior to 5.6.4 and 6.0.0 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.
Affected packages
| Package | Versions |
|---|---|
| Go · github.com/elastic/beats | introduced 0, fixed 5.6.4 |
| Go · github.com/elastic/beats | introduced 6.0.0-alpha1, fixed 6.0.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-11480 ADVISORY
- https://github.com/elastic/beats/pull/5457 WEB
- https://github.com/elastic/beats/pull/5479 WEB
- https://github.com/elastic/beats/pull/5480 WEB
- https://github.com/elastic/beats/commit/aeca65779d573976981587ca1d1461399e1b59dd WEB
- https://discuss.elastic.co/t/beats-5-6-4-security-update/106739 WEB
- https://github.com/elastic/beats PACKAGE
- https://pkg.go.dev/vuln/GO-2022-0643 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |