GHSA-9p95-fxvg-qgq2

simple-git vulnerable to Remote Code Execution when enabling the ext transport protocol

At a glance

Published
Updated
CVE
CVE-2022-25912
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

The package simple-git before 3.15.0 is vulnerable to Remote Code Execution (RCE) when enabling the `ext` transport protocol, which makes it exploitable via `clone()` method. This vulnerability exists due to an incomplete fix of [CVE-2022-24066](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-2434306).

Affected packages

PackageVersions
npm · simple-gitintroduced 0, fixed 3.15.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database