GHSA-9p3v-wf2w-v29c

Moderate severity vulnerability that affects rails

At a glance

Published
Updated
CVE
CVE-2009-4214

Description

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Affected packages

PackageVersions
RubyGems · railsintroduced 0, fixed 2.2.2
RubyGems · railsintroduced 2.3.0, fixed 2.3.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database