GHSA-9jcv-v4jp-w3cq
Cross-site Scripting in Jenkins Core
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2018-1000170
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Description
A cross-site scripting vulnerability exists in Jenkins 2.115 and older, LTS 2.107.1 and older, in confirmationList.jelly and stopButton.jelly that allows attackers with Job/Configure and/or Job/Create permission to create an item name containing JavaScript that would be executed in another user's browser when that other user performs some UI actions.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.108, fixed 2.116 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.107.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000170 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/07d18cfd6d336a2b7cc0a78e120d9739a5d4e1d1 WEB
- https://jenkins.io/security/advisory/2018-04-11/#SECURITY-759 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |