GHSA-9j7m-rjqx-48vh

RubyGems Regular Expression Denial of Service vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2013-4287

Description

Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in `lib/rubygems/version.rb` in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.

Paquets affectés

PaquetVersions
RubyGems · rubygems-updateintroduced 0, fixed 1.8.23.1
RubyGems · rubygems-updateintroduced 1.8.24, fixed 1.8.26
RubyGems · rubygems-updateintroduced 2.0.0, fixed 2.0.8
RubyGems · rubygems-updateintroduced 2.1.0.rc.1, fixed 2.1.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database