GHSA-9j49-mfvp-vmhm
Code Injection in pac-resolver
At a glance
- Published
- Updated
- CVE
- CVE-2021-23406
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. **NOTE:** The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.
Affected packages
| Package | Versions |
|---|---|
| npm · pac-resolver | introduced 0, fixed 5.0.0 |
| npm · degenerator | introduced 0, fixed 3.0.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-23406 ADVISORY
- https://github.com/TooTallNate/node-degenerator/commit/9d25bb67d957bc2e5425fea7bf7a58b3fc64ff9e WEB
- https://github.com/TooTallNate/node-degenerator/commit/ccc3445354135398b6eb1a04c7d27c13b833f2d5 WEB
- https://github.com/TooTallNate WEB
- https://github.com/TooTallNate/node-pac-resolver/releases/tag/5.0.0 WEB
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1568506 WEB
- https://snyk.io/vuln/SNYK-JS-PACRESOLVER-1564857 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |