GHSA-9j49-mfvp-vmhm

Code Injection in pac-resolver

At a glance

Published
Updated
CVE
CVE-2021-23406
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. **NOTE:** The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.

Affected packages

PackageVersions
npm · pac-resolverintroduced 0, fixed 5.0.0
npm · degeneratorintroduced 0, fixed 3.0.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database