GHSA-9gqg-3fxr-9hv7
Apache Airflow vulnerable to XSS
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2017-17836
- Alias
- PYSEC-2019-149
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
In Apache Airflow 1.8.2 and earlier, an experimental Airflow feature displayed authenticated cookies, as well as passwords to databases used by Airflow. An attacker who has limited access to airflow, weather it be via XSS or by leaving a machine unlocked can exfil all credentials from the system.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 1.9.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2017-17836 ADVISORY
- https://github.com/advisories/GHSA-9gqg-3fxr-9hv7 ADVISORY
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-149.yaml WEB
- https://lists.apache.org/thread.html/ade4d54ebf614f68dc81a08891755e60ea58ba88e0209233eeea5f57@%3Cdev.airflow.apache.org%3E WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |