GHSA-9g2w-5f3v-mfmm

Insecure default config of Celery worker in Apache Airflow

En bref

Publiée
Mise à jour
CVE
CVE-2020-11982
Alias
BIT-airflow-2020-11982, PYSEC-2020-16
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 1.10.11

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database