GHSA-9cmq-m9j5-mvww
Spring Framework vulnerable to Denial of Service
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2024-38808
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
Description
In Spring Framework versions 5.3.0 - 5.3.38 and older unsupported versions, it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial of service (DoS) condition. Older, unsupported versions are also affected. Specifically, an application is vulnerable when the following is true: * The application evaluates user-supplied SpEL expressions.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.springframework:spring-expression | introduced 0, fixed 5.3.39 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2024-38808 ADVISORY
- https://github.com/spring-projects/spring-framework/commit/26f2dad388499faecf99e75b8856788e95d8d658 WEB
- https://github.com/spring-projects/spring-framework/commit/f44d13cb7816e586b86c02421af4f5498391111c WEB
- https://github.com/spring-projects/spring-framework PACKAGE
- https://security.netapp.com/advisory/ntap-20240920-0002 WEB
- https://spring.io/security/cve-2024-38808 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |