GHSA-9c2j-593q-3g82

activesupport Improper Input Validation vulnerability

At a glance

Published
Updated
CVE
CVE-2013-1856

Description

The `ActiveSupport::XmlMini_JDOM` backend in `lib/active_support/xml_mini/jdom.rb` in the Active Support component in Ruby on Rails 3.0.x and 3.1.x before 3.1.12 and 3.2.x before 3.2.13, when JRuby is used, does not properly restrict the capabilities of the XML parser, which allows remote attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving (1) an external DTD or (2) an external entity declaration in conjunction with an entity reference.

Affected packages

PackageVersions
RubyGems · activesupportintroduced 3.0.0, fixed 3.1.12
RubyGems · activesupportintroduced 3.2.0, fixed 3.2.13

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database