GHSA-9c24-g32g-35rj
Drupal PECL YAML parser unsafe object handling
At a glance
- Published
- Updated
- CVE
- CVE-2017-6920
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.
Affected packages
| Package | Versions |
|---|---|
| Packagist · drupal/core | introduced 8.0, fixed 8.3.4 |
| Packagist · drupal/drupal | introduced 8.0, fixed 8.3.4 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-6920 ADVISORY
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2017-6920.yaml WEB
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2017-6920.yaml WEB
- https://github.com/drupal/core PACKAGE
- https://www.drupal.org/SA-CORE-2017-003 WEB
- https://www.drupal.org/forum/newsletters/security-advisories-for-drupal-core/2017-06-21/drupal-core-multiple WEB
- http://www.securityfocus.com/bid/99211 WEB
- http://www.securitytracker.com/id/1038781 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |