GHSA-99qx-5qqr-4j95

Apache ActiveMQ has an Incorrect Default Permissions vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2026-49157
Alias
BIT-activemq-2026-49157
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Incorrect Default Permissions vulnerability in Apache ActiveMQ. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.activemq:apache-activemqintroduced 0, fixed 5.19.7
Maven · org.apache.activemq:apache-activemqintroduced 6.0.0, fixed 6.2.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database