GHSA-99cv-8cvv-666c

Apache Airflow vulnerable to Stored XSS

En bref

Publiée
Mise à jour
CVE
CVE-2018-20244
Alias
PYSEC-2019-142
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 1.10.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database