GHSA-97rh-rhh2-7vjv

Payload: Remote Code Execution through first-register

At a glance

Published
Updated
CVE
CVE-2026-105858
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

### Impact A crafted request to the public first-register operation can be used to perform a RCE exploit. **You are affected if:** - You use local auth strategy and your application remains without an initial user created ## Patches In the patched version data submission to create first user is properly sanitized. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.

Affected packages

PackageVersions
npm · payloadintroduced 0, fixed 3.90.0
npm · payloadintroduced 4.0.0-canary.0, fixed 4.0.0-canary.34

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database