GHSA-93pj-4p65-qmr9

Insufficient user authorization in Moodle

En bref

Publiée
Mise à jour
CVE
CVE-2022-0334
Alias
BIT-moodle-2022-0334
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Description

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. Insufficient capability checks could lead to users accessing their grade report for courses where they did not have the required gradereport/user:view capability.

Paquets affectés

PaquetVersions
Packagist · moodle/moodleintroduced 3.11, fixed 3.11.5
Packagist · moodle/moodleintroduced 3.10, fixed 3.10.8
Packagist · moodle/moodleintroduced 0, fixed 3.9.11

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database