GHSA-933g-v89r-x8pf
Apache Dubbo vulnerable to Deserialization of Untrusted Data
At a glance
- Published
- Updated
- CVE
- CVE-2023-23638
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
A deserialization vulnerability existed when dubbo generic invoke, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.21 and prior versions; Apache Dubbo 3.0.x version 3.0.13 and prior versions; Apache Dubbo 3.1.x version 3.1.5 and prior versions.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.dubbo:dubbo | introduced 0, fixed 2.7.22 |
| Maven · org.apache.dubbo:dubbo | introduced 3.0.0, fixed 3.0.13 |
| Maven · org.apache.dubbo:dubbo | introduced 3.1.0, fixed 3.1.5 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-23638 ADVISORY
- https://lists.apache.org/thread/8h6zscfzj482z512d2v5ft63hdhzm0cb WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |