GHSA-932v-x9x2-vq29
Hive Metastore Server is vulnerable to SQL Injection
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-62728
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Description
SQL injection vulnerability in Hive Metastore Server (HMS) when processing delete column statistics requests via the Thrift APIs. The vulnerability is only exploitable by trusted/authorized users/applications that are allowed to call directly the Thrift APIs. In most real-world deployments, HMS is accessible to only a handful of applications (e.g., Hiveserver2) thus the vulnerability is not exploitable. Moreover, the vulnerable code cannot be reached when metastore.try.direct.sql property is set to false. This issue affects Apache Hive: from 4.1.0 before 4.2.0. Users are recommended to upgrade to version 4.2.0, which fixes the issue. Users who cannot upgrade directly are encouraged to set metastore.try.direct.sql property to false if the HMS Thrift APIs are exposed to general public.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.apache.hive:hive-common | introduced 4.1.0, fixed 4.2.0 |
| Maven · org.apache.hive:hive-metastore | introduced 4.1.0, fixed 4.2.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2025-62728 ADVISORY
- https://github.com/apache/hive/commit/c18d0df2702130cf5d0f050e516eb8999aa56301 WEB
- https://github.com/apache/hive PACKAGE
- https://issues.apache.org/jira/browse/HIVE-29269 WEB
- https://lists.apache.org/thread/yj65dd8dmzgy8p3nv8zy33v8knzg9o7g WEB
- http://www.openwall.com/lists/oss-security/2025/11/26/3 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |