GHSA-92xg-gmrq-5c3w

Apache Airflow vulnerable to Execution with Unnecessary Privileges

En bref

Publiée
Mise à jour
CVE
CVE-2024-45034
Alias
BIT-airflow-2024-45034, PYSEC-2024-212
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

Apache Airflow versions before 2.10.1 have a vulnerability that allows DAG authors to add local settings to the DAG folder and get it executed by the scheduler, where the scheduler is not supposed to execute code submitted by the DAG author. Users are advised to upgrade to version 2.10.1 or later, which has fixed the vulnerability.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.10.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database