GHSA-92cc-952p-v8rh
Apache Hadoop HDFS Native Client has Out-of-bounds Write Vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-27821
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Description
Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.apache.hadoop:hadoop-hdfs-native-client | introduced 3.2.0, fixed 3.4.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2025-27821 ADVISORY
- https://github.com/apache/hadoop/pull/7481 WEB
- https://github.com/apache/hadoop/commit/2b32e46f666c7645f5d1e026be3982b99319ccb8 WEB
- https://github.com/apache/hadoop PACKAGE
- https://issues.apache.org/jira/browse/HDFS-17754 WEB
- https://lists.apache.org/thread/kwjhyyx0wl2z9b0mw0styjk0hhdbyplh WEB
- http://www.openwall.com/lists/oss-security/2026/01/23/7 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |