GHSA-923p-fr2c-g5m2

Exposure of Sensitive Information to an Unauthorized Actor in Ansible

At a glance

Published
Updated
CVE
CVE-2020-1739
Aliases
PYSEC-2020-11
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Description

A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

Affected packages

PackageVersions
PyPI · ansibleintroduced 0, fixed 2.7.17
PyPI · ansibleintroduced 2.8.0a1, fixed 2.8.11
PyPI · ansibleintroduced 2.9.0a1, fixed 2.9.7

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database